设为首页 加入收藏

TOP

vscode解决nuget插件不能使用的问题
2019-10-11 11:20:01 】 浏览:429
Tags:vscode 解决 nuget 插件 不能 使用 问题

错误提示

使用vscode安装nuget插件之后出现错误:

"Versioning information could not be retrieved from the NuGet package repository. Please try again later."

原因

主要是nuget插件里的拉组件的js文件没有进行小写的控制

解决

打开路径下的文件fetchPackageVersions.js

/Users/用户名/.vscode/extensions/jmrog.vscode-nuget-package-manager-1.1.6/out/src/actions/add-methods/fetchPackageVersions.js

修改代码

...node_fetch_1.default(`${versionsUrl}${selectedPackageName}/index.json`, utils_1.getFetchOptions(vscode.workspace.getConfiguration('http')))

修改后的代码了toLowerCase()方法

...node_fetch_1.default(`${versionsUrl}${selectedPackageName.toLowerCase()}/index.json`, utils_1.getFetchOptions(vscode.workspace.getConfiguration('http')))

重启vscode问题解决!

】【打印繁体】【投稿】【收藏】 【推荐】【举报】【评论】 【关闭】 【返回顶部
上一篇一步一步剖析Dictionary实现原理 下一篇(八十二)c#Winform自定义控件-..

最新文章

热门文章

Hot 文章

Python

C 语言

C++基础

大数据基础

linux编程基础

C/C++面试题目