设为首页 加入收藏

TOP

Caused by: com.fasterxml.jackson.databind.JsonMappingException: Incompatible Jackson version: 2.9.6
2018-12-06 17:27:43 】 浏览:9
Tags:Caused by: com.fasterxml.jackson.databind.JsonMappingException: Incompatible Jackson version: 2.9.6
版权声明:本文为王小雷原创文章,未经博主允许不得转载 https://blog.csdn.net/dream_an/article/details/82427301

问题:spark实时处理数据报错 Spark Structured Streaming kafka 报错 Caused by: com.fasterxml.jackson.databind.JsonMappingException: Incompatible Jackson version: 2.9.6

这里写图片描述

问题在于spark目前使用的Jackson是2.6+,而storm-kafka-client和kafka使用的是2.9+,两者之间gradle默认使用最新的依赖2.9+,所以spark structure Streaming程序运行时报错,不兼容jackson高版本。

解决:

gradle 修改如下

    compile (group: 'org.apache.storm', name: 'storm-kafka-client', version: '1.2.2'){
       //解决与spark core jackson版本冲突
        exclude group:"com.fasterxml.jackson.core"
    }
    compile (group: 'org.apache.kafka', name: 'kafka_2.11', version: '1.1.1'){
        exclude group:"com.fasterxml.jackson.core"
    }

正常运行
这里写代码片


编程开发网
】【打印繁体】【投稿】【收藏】 【推荐】【举报】【评论】 【关闭】 【返回顶部
上一篇Spark电商用户行为分析1 下一篇Spark 2.3.0+Kubernetes应用程序..

评论

帐  号: 密码: (新用户注册)
验 证 码:
表  情:
内  容:

array(4) { ["type"]=> int(8) ["message"]=> string(24) "Undefined variable: jobs" ["file"]=> string(32) "/mnt/wp/cppentry/do/bencandy.php" ["line"]=> int(214) }