TOP

hadoop版本与支持的hbase版本对照表
2018-11-23 01:53:39 】 浏览:678
Tags:hadoop 版本 支持 hbase 对照表

As of Hive 0.9.0 the HBase integration requires at least HBase 0.92, earlier versions of Hive were working with HBase 0.89/0.90

以下内容来自下载的HBASE-0.94.7的book中( $HBASE_HOME/docs/book/configuration.html)



HBase-0.92.x



HBase-0.94.x


HBase-0.96


Hadoop-0.20.205



S



X



X



Hadoop-0.22.x



S



X



X



Hadoop-1.0.x



S



S



S



Hadoop-1.1.x



NT



S



S



Hadoop-0.23.x



X



S



NT



Hadoop-2.x



X



S



S


S = 支持且已测试,
X = 不支持,
NT = 可以运行,但未充分测试。

------------------------------------------------------------------------------------------------------------------------------

以下内容来自:HBASE官网

HBase-0.92.x

HBase-0.94.x

HBase-0.95

Hadoop-0.20.205

S

X

X

Hadoop-0.22.x

S

X

X

Hadoop-1.0.0-1.0.2[a]

S

S

X

Hadoop-1.0.3+

S

S

S

Hadoop-1.1.x

NT

S

S

Hadoop-0.23.x

X

S

NT

Hadoop-2.x

X

S

S

[a]HBase至少得hadoop 1.0.3; 在Hadoop早期版本中有一个问题——无法找到编译KerberosUtil。


S = 支持且已测试,
X = 不支持,
NT = 可以运行,但未充分测试。

来源:http://hbase.apache.org/book/configuration.html#hadoop


hadoop版本与支持的hbase版本对照表 https://www.cppentry.com/bencandy.php?fid=118&id=185553

】【打印繁体】【投稿】【收藏】 【推荐】【举报】【评论】 【关闭】 【返回顶部
上一篇HBase优化学习 下一篇HBase 数据备份