设为首页 加入收藏

TOP

Python 多版本共存问题 1
2019-02-13 02:55:20 】 浏览:25
Tags:Python 版本 共存 问题

Python 多版本共存问题 1

Python 3 和 Python 2 ?

自从 Python 发布新的版本 3 以来,就一直是开发者心中的一个纠结。由于 Python 3 并不完全兼容 Python 2的语法,这导致大量的Python 2时代的优秀module在Python 3中无法使用,这些module的开发者自身也感到并没有令人特别激动的理由让自己用Python 3来对module进行重写,这导致大家都继续集体停留在Python 2的乐园里。

另一方面,Python 3在世界上还是有诸多拥趸,新开发出来的module大多数都是采用 Python 3规范进行编写,例如 tensorflow,numpy 等都发布Python 2和3两种版本。

除此之外,Python 2内部也有 2.5, 2.7等版本,Python 3内部也有 3.4, 3.5等版本。

多版本共存的刚需

由于开发任务的不同,例如hedes可能需要采用Python 3的某个爬虫库,用以采集网络文本数据,然后利用tensorflow来开发深度学习的文本情感分类算法。那么此时张三就需要调用Python 3版本下的多个库,而目前张三的Ubuntu 服务器上只有Python 2.7,因此他需要安装python 3并安装对应的python 3 module

Ubuntu 14.04 安装Python 3

hedes的服务器是联想的P900 工作站,安装的系统是Ubuntu 14.04,显卡是NV-Titan-X。

Ubuntu 14.04 系统已经原生安装了 Python 2.7

  • 安装 Python 3

    Python 3 采用 apt-get 默认安装到 /usr/bin/python3

    sudo apt-get install python3#目前系统上默认安装 Python 3.4
    
  • 安装 Python 3.4 or 3.5

    • Python 3.4 采用 apt-get 默认安装到 /usr/bin/python3.4

      sudo apt-get install python3.4
      
    • Python 3.5 采用 apt-get 默认安装到 /usr/bin/python3.5

      # 添加 ppa
      sudo add-apt-repository ppa:fkrull/deadsnakes
      sudo apt-get update
      sudo apt-get install python3.5
      
  • 安装 Python 3的库

    • 采用 apt-get 方式的安装

      • 安装 Python 3的库(以numpy为例),安装位置是 /usr/lib/python3/dist-packages/

        sudo apt-get install python3-numpy
        
      • 安装 Python 3.4的库

        • 因为其实目前无法安装 python3.4-numpy 或者 python3.5-numpy,我估计是因为目前的python3-numpy 包对Python 3的任意版本都是通用
        • 如果要安装 python3.4-name1 的库,那么安装的位置是 /usr/lib/python3.4/dist-packages
    • 采用 pip 的方式安装

      • 安装 Python 3的库(以 numpy 为例),安装位置是 /usr/local/lib/python3/dist-packages

        # 采用 pip3 进行安装之前,先安装 python3.4-dev
        sudo apt-get install python3.4-dev
        # 如果之前已经通过 apt-get 安装过了 python3-numpy,那么这里将不会对 numpy 进行安装
        sudo pip3 install numpy
        
        # 值得注意的是,如果先用 pip3 安装了numpy,那么 python3-numpy 还是可以用 apt-get 进行安装...,但是Python 2中就不是这样,如果已经用pip 安装过了 numpy,那么 python-numpy 就不会被安装...anyway,总之是装上了模块了
        
        • 查看 module 的位置

          # python3.4
          import numpy as np
          print(np.__path__)
          
      • 欲采用 pip 安装 Python 3.4 or Python 3.5 的库,则需要用到 virtualenv 命令,在独立环境中用 pip 进行安装,详细参照本文的下一篇

Shell 中调用Python 的不同版本

假设我们将 Python 每种版本对应的 module 都采用 pip2 or pip3进行安装,那么我们可以采用如下的方式来调用 Python 2 和 Python 3

  • 小贴士

    # 查看 Python 这个可执行程序的位置
    which python
    # 查看 Python 这个文件名或文件夹名在系统中出现的位置
    # locate 跟 find 不同,find 是直接硬查找,而locate 是查询系统中的数据库来快速定位相关 name 出现的位置
    locate python
    
  • shell 中调用 Python 2

    # 以下三种方式都可以调用 Python 2.7
    python
    python2
    python2.7
    
  • shell 中调用 Python 3

    # 前两种方式调用的是 Python 3.4
    python3
    python3.4
    # 该种方式调用的是 Python 3.5
    python3.5
    
  • 进入 Python 的解释器后,就可以 import 各种module了,只要这个模块存在于对应Python 版本的lib中


编程开发网
】【打印繁体】【投稿】【收藏】 【推荐】【举报】【评论】 【关闭】 【返回顶部
上一篇安装python工具 easy_install &nb.. 下一篇Python第六天   类型转换