设为首页 加入收藏

TOP

poj-1651 multiplication puzzle(区间dp)
2018-10-21 18:08:22 】 浏览:32
Tags:poj-1651 multiplication puzzle 区间

Time limit1000 ms

Memory limit65536 kB

 

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650
题意:头尾不动,每次都取一个数,使得它和它的两边的数相乘为去掉这个数的价值,问直到只剩下头尾所需的最小价值
题解:求出每个区间的最小值,直到扩充到整个区间,区间dp
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<stack>
using namespace std;
#define PI 3.14159265358979323846264338327950
#define INF 0x3f3f3f3f;

int n,i,j,k,l;
int dp[110][110];
int a[1010];
void solve()
{
    for(l=2;l<=n;l++)
    {
        for(i=2;i+l<=n+1;i++)
        {
            j=i+l-1;
            dp[i][j]=INF;
            for(k=i;k<j;k++)
                dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i-1]*a[k]*a[j]);
        }
    }
    printf("%d\n",dp[2][n]);
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
       for(int i=1;i<=n;i++)
          cin>>a[i];
      solve();
    }
}

 

】【打印繁体】【投稿】【收藏】 【推荐】【举报】【评论】 【关闭】 【返回顶部
上一篇DirectX11 With Windows SDK--17 .. 下一篇Meteor Shower POJ - 3669 (bfs+..

最新文章

热门文章

Hot 文章

Python

C 语言

C++基础

大数据基础

linux编程基础

C/C++面试题目